Worldspan Go!®  Now Compatible with Internet Explorer 8
Travelport has completed compatibility testing of Worldspan Go! and Internet Explorer 8 (I.E. 8).
Internet Explorer 8 is now on the list of browser versions supported for use with Worldspan Go! If your office receives automatic updates from Microsoft you may now download the latest version of Internet Explorer.
Go! Dateline